ADEOS, ADEOS-IPIPE and RTAI-3.2

Paolo Mantegazza mantegazza at aero.polimi.it
Fri Jan 27 13:23:34 CET 2006


Bruckmann, Tobias wrote:
> Hi,
> 
> today I tried to install RTAI-3.2 based on the brand-new 2.6.15 kernel. First, I downloaded the correct ADEOS patch and patched my kernel sources and compiled. First thing I didn't understand (and I guess, this is why it didn't work), that he option "ADEOS" inside the "processor"-folder of the kernel options was gone. I found something like "interrupt pipeling" (=IPIPE?) which seems to replace this option.
> 
> My hope was that this IPIPE for the new kernel versions (which seems to be the only available patch on the ADEOS homepage for kernels after 2.6.12) has more or less the same purpose that ADEOS for older kernels has, but RTAI doesn't seem to be happy with IPIPE instead of ADEOS:
> 
> configure: error: HAL patch not applied/enabled in /usr/src/linux-2.6.15.1
> 
> Is there a possibility to tell RTAI to search for the new replacement, or should I switch back to a kernel supported by "old-style"-ADEOS? This would be absolutely no problem, I'd just like to know if there is the possibility to work with RTAI-3.2 (it has to be this version) and latest kernels...
> 

3.2 is stucked to the patches he had. If you begin using 3.3 you'll have it.

Paolo.





More information about the Rtai mailing list