=1GB issue solved :-)

Hannes Mayer h.mayer at inode.at
Mon Jul 24 21:55:24 CEST 2006


Calin A. Culianu wrote:
> 
> I thought the 1GB issue was only on 2.6 kernels anyway?

hmm...well... now as you mention it I'm not sure if I saw
this with 2.4.32 back then with 3.2.

Anyway, I've tried 2.6.17.6 now and the problem seems to
be still there. (see below)
The wake_up_common and ext3* looks familiar...

An "improvement" seems to be that the machine didn't lock
up this time.

Best regards,
Hannes

RTAI[malloc]: vfreed extent f8903000, size 2097152.
RTAI[malloc]: unloaded.
RTAI[sched]: unloaded (forced hard/soft/hard transitions: traps 0, syscalls 0).
I-pipe: Domain RTAI unregistered.
RTAI[hal]: unmounted.
RTAI: Intel chipset found, enabling SMI workaround.
SMI module loaded
I-pipe: Domain RTAI registered.
RTAI[hal]: <3.4-test2> mounted over IPIPE-NOTHREADS 1.3-08.
RTAI[hal]: compiled with gcc version 3.3.5 (Debian 1:3.3.5-13).
RTAI[hal]: mounted (IPIPE-NOTHREADS, IMMEDIATE (INTERNAL IRQs VECTORED), ISOL_CPUS_MASK: 0).
PIPELINE layers:
f88c0f80 9ac15d93 RTAI 200
c03037e0 0 Linux 100
RTAI[malloc]: vmalloced extent f8903000, size 2097152.
RTAI[malloc]: loaded (global heap size=2097152 bytes).
RTAI[sched]: loaded (IMMEDIATE, UP, USER/KERNEL SPACE<with RTAI TASKs>: ).
RTAI[sched]: hard timer type/freq = APIC/6250250(Hz); default timing mode is periodic; linear ordering of timed lists.
RTAI[sched]: Linux timer freq = 250 (Hz), CPU freq = 1400313000 hz.
RTAI[sched]: timer setup = 999 ns, resched latency = 2943 ns.
BUG: unable to handle kernel paging request at virtual address 4183fcb5
  printing eip:
c18003f9
*pde = 00000000
Oops: 0000 [#1]
PREEMPT
Modules linked in: latency_rt rtai_fifos rtai_sched rtai_hal smi de4x5 agpgart tulip crc32 psmouse ide_cd cdrom genrtc unix
CPU:    0
EIP:    0060:[<c18003f9>]    Not tainted VLI
EFLAGS: 00010206   (2.6.17.6-vulcano #1)
EIP is at 0xc18003f9
eax: c18003f4   ebx: c18003f0   ecx: 00000001   edx: 00000003
esi: c1800400   edi: 00000001   ebp: f65e7cc8   esp: f65e7ca8
ds: 007b   es: 007b   ss: 0068
Process dd (pid: 1040, threadinfo=f65e6000 task=ee599540)
Stack: c01160e1 c18003f4 00000003 00000000 f65e7d04 00000000 f65e7d04 00000001
        f65e7cf8 c011616b c1800000 00000003 00000001 00000000 f65e7d04 00000003
        c1800000 c1800000 00001000 00001000 f4aa6e44 c0133078 f65e7d04 c1006da0
Call Trace:
  <c01160e1> __wake_up_common+0x41/0x70  <c011616b> __wake_up+0x5b/0xc0
  <c0133078> __wake_up_bit+0x38/0x40  <c0142e42> generic_file_buffered_write+0x2f2/0x6f0
  <c01265e2> run_timer_softirq+0x1a2/0x290  <c012fb4a> __rcu_process_callbacks+0x5a/0x130
  <c0143575> __generic_file_aio_write_nolock+0x335/0x600  <f88bb759> _rtai_apic_timer_handler+0x59/0x114 [rtai_hal]
  <c0102e1f> restore_raw+0x0/0xd  <c0143aec> generic_file_aio_write+0x7c/0xf0
  <c01b0714> ext3_file_write+0x44/0xd0  <c01659d1> do_sync_write+0xc1/0x110
  <c0132f80> autoremove_wake_function+0x0/0x60  <c020ed44> read_zero+0x1c4/0x210
  <c0165ace> vfs_write+0xae/0x180  <c0165c71> sys_write+0x51/0x80
  <c0102dea> syscall_call+0x7/0xb
Code: 80 c1 d0 03 80 c1 d0 03 80 c1 d8 03 80 c1 d8 03 80 c1 e0 03 80 c1 e0 03 80 c1 e8 03 80 c1 e8 03 80 c1 f0 03 80 c1 f0 03 80 c1 f8 <03> 80 c1 f8 03 80 c1 00 04 80 c1 00 04 80 c1 08 04 80 c1 08 04
EIP: [<c18003f9>] 0xc18003f9 SS:ESP 0068:f65e7ca8
  <6>note: dd[1040] exited with preempt_count 1
Bad page state in process 'bash'
page:c17f3760 flags:0xc0000400 mapping:00000000 mapcount:0 count:0
Trying to fix it up, but a reboot is needed
Backtrace:
  <c014558f> bad_page+0x5f/0xa0  <c0145f18> free_hot_cold_page+0x198/0x1b0
  <c014f7a0> zap_pte_range+0x1c0/0x280  <c014f933> unmap_page_range+0xd3/0x140
  <c014fa8d> unmap_vmas+0xed/0x210  <c0154d9a> exit_mmap+0x7a/0x150
  <c0117e11> mmput+0x41/0x110  <c011e2e2> do_exit+0xf2/0x620
  <c011e87c> do_group_exit+0x3c/0xd0  <c0102dea> syscall_call+0x7/0xb




More information about the Rtai mailing list