[Rtai] I cannot go by RTAI-3.6 whit kernel 2.6.23

Dusan Saljic saljic at yahoo.com
Wed May 7 10:39:06 CEST 2008



Hi,

Your initrd image is not correct, possibly because is not '1-1' to your kernel image, or some of the core modules are not into it. 
Try the following:
 - If you have initramfs try: # mkinitramfs -o /boot/initrams-2.6.23-rtai.img 2.6.23 (or 2.6.23-rtai) depends how you did your kernel configuration. Try to bood this with initramfs image if still doesn't boot, you should copy your System.map and bzImage again. 

Check your mkinitrd.conf, mine is at /etc/mkinitrd/mkinitrd.conf and modules shouls MOST be, and the same for mkinitramfs.conf, which by me, located in /etc/initramfs-tools/initramfs.conf

Regards,
Dusan.



----- Original Message ----
From: "yfcabezas at unicauca.edu.co" <yfcabezas at unicauca.edu.co>
To: mantegazza at aero.polimi.it; rtai at rtai.org
Sent: Tuesday, May 6, 2008 11:04:28 PM
Subject: [Rtai] I cannot go by RTAI-3.6 whit kernel 2.6.23

Hi!!  Again 

After, I tried running my RT-task, I decided install rtai-3.6 with kernel 2.6.23, the instalacion had no problems, but when I go by the new kernel compiled to start the system appears on the screen:

Booting 'Fedora Core (2.6.23-rtai)'
root(hd0,5)
Filesystem  type is ext2fs, partition type 0x83
karnel /boot/vmlinuz-2.6.23-rtai ro root=LABEL=/, hgb quiet
[Linux -bzImage, setup=0x2800 , size=0x1873c8]
initrd /boot/initrd-2.6.23-rtai.img
[Linux-initrd @ 0x1bf80000, 0x5fa66 bytes]


Uncompressing Linux ... OK, booting the kernel
Red Hat nash version 4.1.18 starting
Enforcing mode request but no policy loaded, Halting now
kernel panic-not syncing: Attempted to kill init!

What is your opinion??
My distro is the same Fedora Core3
I need your help again!!



Yonny Fernando Cabezas Ortiz
Ingineering  Automatic Industrial
University of the Cauca - Colombia


--------------------------------------
MENSAJE ENVIADO CON WMAIL 1.01
UNIVERSIDAD DEL CAUCA


_______________________________________________
Rtai mailing list
Rtai at rtai.org
https://mail.rtai.org/cgi-bin/mailman/listinfo/rtai



      ____________________________________________________________________________________
Be a better friend, newshound, and 
know-it-all with Yahoo! Mobile.  Try it now.  http://mobile.yahoo.com/;_ylt=Ahu06i62sR8HDtDypao8Wcj9tAcJ
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mail.rtai.org/pipermail/rtai/attachments/20080507/946da25b/attachment.htm 


More information about the Rtai mailing list