[Rtai] Resolved: patched 2.6.32.11 Kernel hangs at early boot time

Friedemann Bunjes friedemann.bunjes at uni-tuebingen.de
Mon Sep 19 08:13:10 CEST 2011


Hi,

>> After patching it with rtai-3.8.1/base/arch/x86/patches/hal-linux-2.6.32.11-x86-2.6-03.patch the boot hangs at the very beginning with a black screen (and cursor). /var/log/messages contains no very useful information (see below).
> 
> https://mail.rtai.org/pipermail/rtai/2011-August/024687.html
> 
> Any chance you're seeing this problem?
> 
> After applying the patch mentioned there, hal-linux-2.6.32.20-x86-2.7-03.patch worked fine for me on Ubuntu 10.04.
> 

thanks for the hint.
I solved the problem by using a kernel config I found here:
http://mekabot.com/wiki/doku.php?id=m3:installation:installation_v1.3
(see Attachment)

Seems, that the correct configuration solves (?) the problem.

All the best,

Friedemann

-------------- next part --------------
A non-text attachment was scrubbed...
Name: config-2.6.32.11
Type: application/octet-stream
Size: 103882 bytes
Desc: not available
URL: <http://mail.rtai.org/pipermail/rtai/attachments/20110919/be86f115/attachment-0001.obj>
-------------- next part --------------

-- 
Dr. rer. nat. Friedemann Bunjes
Hertie-Institut f?r Klinische Hirnforschung
Zentrum f?r Neurologie
Universit?tsklinikum T?bingen
Otfried-M?ller-Str. 27
72076 T?bingen
+49-7071-29-81999



More information about the Rtai mailing list