[Rtai] rtai_hal: Unknown symbol irq_desc (err 0)

mantegazza at aero.polimi.it mantegazza at aero.polimi.it
Fri Mar 23 21:53:05 CET 2012


Is a n issu I'm on, Can you confirm it happens with 2.6.38 and scatter
interrupts activated in Linux

paolo

> Hello,
>
> Both the vulcano repository and rtai-3.9-test2 have this warning. This
> seems to be preventing the modules from loading with an
> insmod/modprobe.
>
> Excerpt from vulcano cvs repo:
>
> make[6]: Entering directory `/home/j/dev/kernel/src/linux-2.6.38.8'
>   CC [M]  /home/j/dev/kernel/src/rtai-cvs/vulcano/base/arch/i386/hal/hal.o
>   CC [M]  /home/j/dev/kernel/src/rtai-cvs/vulcano/base/arch/i386/hal/rtc.o
>   LD [M]
> /home/j/dev/kernel/src/rtai-cvs/vulcano/base/arch/i386/hal/rtai_hal.o
>   Building modules, stage 2.
>   MODPOST 1 modules
> WARNING: "irq_desc"
> [/home/j/dev/kernel/src/rtai-cvs/vulcano/base/arch/i386/hal/rtai_hal.ko]
> undefined!
>   CC
> /home/j/dev/kernel/src/rtai-cvs/vulcano/base/arch/i386/hal/rtai_hal.mod.o
>   LD [M]
> /home/j/dev/kernel/src/rtai-cvs/vulcano/base/arch/i386/hal/rtai_hal.ko
> make[6]: Leaving directory `/home/j/dev/kernel/src/linux-2.6.38.8'
>
> Excerpt from rtai-3.9-test2:
>
> make[7]: Entering directory `/home/j/dev/kernel/src/linux-2.6.38.8'
>   CC [M]  /home/j/dev/kernel/src/rtai-3.9-test2/base/arch/i386/hal/hal.o
>   CC [M]  /home/j/dev/kernel/src/rtai-3.9-test2/base/arch/i386/hal/rtc.o
>   LD [M]
> /home/j/dev/kernel/src/rtai-3.9-test2/base/arch/i386/hal/rtai_hal.o
>   Building modules, stage 2.
>   MODPOST 1 modules
> WARNING: "irq_desc"
> [/home/j/dev/kernel/src/rtai-3.9-test2/base/arch/i386/hal/rtai_hal.ko]
> undefined!
>   CC
> /home/j/dev/kernel/src/rtai-3.9-test2/base/arch/i386/hal/rtai_hal.mod.o
>   LD [M]
> /home/j/dev/kernel/src/rtai-3.9-test2/base/arch/i386/hal/rtai_hal.ko
> make[7]: Leaving directory `/home/j/dev/kernel/src/linux-2.6.38.8'
>
> When I do a modprobe:
>
> modprobe rtai_hal
> FATAL: Error inserting rtai_hal
> (/lib/modules/2.6.38.8-rtai/rtai/rtai_hal.ko): Unknown symbol in
> module, or unknown parameter (see dmesg)
>
> dmesg | tail -2
> [ 1501.786567] rtai_hal: Unknown symbol irq_desc (err 0)
> [ 5822.432290] rtai_hal: Unknown symbol irq_desc (err 0)
>
> Can you please help?
>
> The only reason I tried vulcano/3.9-test2 is because the
> kern/switches/.run testsuite would not run with 3.8.1. It just showed
> me the last few lines of /var/log/kernel. Not sure if that is a known
> issue.
>
> Thanks
> Joe
> _______________________________________________
> Rtai mailing list
> Rtai at rtai.org
> https://mail.rtai.org/cgi-bin/mailman/listinfo/rtai
>




More information about the Rtai mailing list