[Rtai] Div64 compile error

Glen Wernersbach glen at jetsoftdev.com
Tue Mar 27 14:40:25 CEST 2012


I think you are right.

I had to make a link of the ASM-ARM folder in the Linux directory and move
it into the ARCH director of RTAI.

That took care of the div64 error but there were warnings because they are
defined as static.

Two other compile prolems.
1. RTAI_atomic_t.h could not find the atomic_t structure definition. I
hacked it in.
2. I also got the error ldres and sdres were not available for the AT91
processor. Standard error. I gave up after that one.




On 3/26/12 5:25 PM, "masarati at aero.polimi.it" <masarati at aero.polimi.it>
wrote:

>> 
>> Hi all,
>> 
>> Trying to compile 3.8 on arm.
>> 
>> I am getting the include div64.h not found error.
>> 
>> I have hacked around this before but is there a fix for it.
>> 
>> For some reason, the asm location is always messed up on my rtai builds.
> 
> I suspect something related to moving to a more recent autotool chain.
> Can you post more information about the error you encounter?  E.g. what
> logs on the screen, where div64.h is actually located in your system,
> etc.?
> 
> Thanks, p.
> 
> 

-- 
Glen Wernersbach
President & CTO

Jetsoft Development Co.
629 Old St Rt. 74 ­ Suite 210
Cincinnati, Oh 45244
Custom Programming Web Site: www.jetsoftdev.com
Retail Products Web Site: www.scanhelp.com
Phone:   513-528-6660
Fax: 513-528-3470
Cell 513-240-9929
----
Partner for Software Technology
Jacobs Automation
2365 Progress Drive
Hebron, KY 41048 
(513) 297-7550
----
"Support Dyslexia Research"





More information about the Rtai mailing list