[Rtai] Div64 compile error

Torsten Koschorrek devel at koschorrek.com
Wed Mar 28 19:52:27 CEST 2012


Glen Wernersbach wrote:
> I think you are right.
>
> I had to make a link of the ASM-ARM folder in the Linux directory and move
> it into the ARCH director of RTAI.
>
> That took care of the div64 error but there were warnings because they are
> defined as static.
>

Which kernel, is it the 2.6.29 you mentioned in the other thread? The 
last time I compiled RTAI/2.6.20/AT91 I didn't run into that error 
though it sounds familiar to me.

> Two other compile prolems.
> 1. RTAI_atomic_t.h could not find the atomic_t structure definition. I
> hacked it in.

How? I'd like to implement it for future releases.

> 2. I also got the error ldres and sdres were not available for the AT91
> processor. Standard error. I gave up after that one.
>

Also familiar somehow. Could you provide more information, compile log 
or something?

Thanks, Torsten


>
>
>
> On 3/26/12 5:25 PM, "masarati at aero.polimi.it"<masarati at aero.polimi.it>
> wrote:
>
>>>
>>> Hi all,
>>>
>>> Trying to compile 3.8 on arm.
>>>
>>> I am getting the include div64.h not found error.
>>>
>>> I have hacked around this before but is there a fix for it.
>>>
>>> For some reason, the asm location is always messed up on my rtai builds.
>>
>> I suspect something related to moving to a more recent autotool chain.
>> Can you post more information about the error you encounter?  E.g. what
>> logs on the screen, where div64.h is actually located in your system,
>> etc.?
>>
>> Thanks, p.
>>
>>
>



More information about the Rtai mailing list