RTAI3.1 / Kernel 2.4.27 system freeze @ kern/latency

José Antonio Sánchez getaceres at gmail.com
Sun Oct 3 21:17:14 CEST 2004


Every time I had system hangs when running RTAI tests was because a
bad kernel configuration. First, I had problems because I applied the
official adeos patch to the kernel, instead of the one provided with
RTAI (I didn't find this patches due to lack of documentation).
Then I had a problem with this on a C3 processor because I configured
the kernel to compile as a c3 and I had to compile it as a 586tsc
instead to make it work.
I hope this will help you. Look at your kernel configuration. Look if
your processor has tsc or not and configure it always as a 586/686.


On Sun, 03 Oct 2004 17:21:19 +0200, Hannes Mayer <h.mayer at inode.at> wrote:
> Hi all!
> 
> I'm just testing RTAI 3.1 with kernel 2.4.27 (3.0r4/2.4.25 runs fine on the test machine).
> 
> Kernel compiled fine, aswell as RTAI -> reboot -> run kern/latency.
> Then the system froze and I had to push the reset button.
> 
> First I thought it might be because the symlink /usr/bin/gcc was set to gcc-2.95, so I
> started from scratch with gcc 3.3.4, but avail. Still freezes at kern/latency.
> 
> gcc 2.95: kern.log:
> Oct  3 15:20:16 localhost kernel: Adeos: Domain RTAI registered.
> Oct  3 15:20:16 localhost kernel: RTAI[hal]: 3.1 mounted over Adeos 2.4r16/x86.
> Oct  3 15:20:16 localhost kernel: RTAI[hal]: compiled with gcc version 2.95.4 20011002 (Debian prerelease).
> Oct  3 15:20:16 localhost kernel: RTAI[malloc]: loaded (global heap size=131072 bytes).
> Oct  3 15:20:16 localhost kernel: RTAI[sched_smp]: loaded.
> Oct  3 15:20:16 localhost kernel: RTAI[sched_smp]: fpu=yes, timer=periodic (APIC).
> Oct  3 15:20:16 localhost kernel: RTAI[sched_smp]: standard tick=100 hz, CPU freq=1193180 hz.
> Oct  3 15:20:16 localhost kernel: RTAI[sched_smp]: timer setup=838 ns, resched latency=2514 ns.
> [freeze]
> 
> gcc 3.3.4: kern.log:
> Oct  3 18:06:18 localhost kernel: Adeos: Domain RTAI registered.
> Oct  3 18:06:18 localhost kernel: RTAI[hal]: 3.1 mounted over Adeos 2.4r16/x86.
> Oct  3 18:06:18 localhost kernel: RTAI[hal]: compiled with gcc version 3.3.4 (Debian).
> Oct  3 18:06:18 localhost kernel: RTAI[malloc]: loaded (global heap size=131072 bytes).
> Oct  3 18:06:18 localhost kernel: RTAI[sched_smp]: loaded.
> Oct  3 18:06:18 localhost kernel: RTAI[sched_smp]: fpu=yes, timer=periodic (APIC).
> Oct  3 18:06:18 localhost kernel: RTAI[sched_smp]: standard tick=100 hz, CPU freq=1193180 hz.
> Oct  3 18:06:18 localhost kernel: RTAI[sched_smp]: timer setup=838 ns, resched latency=2514 ns.
> [freeze]
> 
> I'm now trying RTAI3.1 with kernel 2.4.25. If that doesn't work, I'll go back to
> RTAI3.0r4 with 2.4.25 and see if I can get a working RTAI again or if my build system
> is damaged.
> 
> Best regards,
> Hannes.
> 
> _______________________________________________
> RTAI mailing list
> RTAI at rtai.org
> https://mail.rtai.org/cgi-bin/mailman/listinfo/rtai
>




More information about the Rtai mailing list