Antwort: Re: help reqd rgd example preempt pls(with denx core)

deepa.vijayaraghavan at mbtech-group.com deepa.vijayaraghavan at mbtech-group.com
Wed Oct 6 09:41:20 CEST 2004


Hi Wolfgang,
   Here, are a few details.
ELDK Ver 3.0
Linux : Linuxppc_2_4_devel
Patch: patch-denx-linuxppc_2_4_devel-LABEL_2004_04_30_1320
RTAI: rtai-24.1.12
The example I am referring to, is the one in rtai-24.1.1/examples/preempt 
directory.
The module gets built when I build the RTAI. 
The ebony board boots up fine. I 'insmod' rtai.o, rtai_fifos.o, 
rtai_sched_up.o. I get all outputs, as it should be, as stated in 
README.install on the denx ftp server.
Then I insmod $MYPATH/rtai-24.1.1/examples/preempt/ex_preempt.o
I run check.
I get no output. I tried adding some rt_printk statements within the while 
loop in the tasks, nothing gets printed. But rmmod returns with no error.
Once I changed the second parameter of the rt_task_make_periodic() 
function to 0, I started getting output, a few times, based on the number 
of times the tasks get scheduled before the completion of the 
init_module() function. 
I do not know why the tasks don't run continuously. 
In rmmod, I checked the return value of rt_task_delete(). No errors. So, 
the tasks do exist! 
I use One shot timer. If I use periodic timer, I get no output at all in 
any case.
I do not understand what you mean by 'can we have a look at the test 
module'. Do you want me to attach the built module, that I have here?

Thank you very much in advance for your help..

Best Regards
Deepa.





  




wolfgang.grandegger at bluewin.ch
Gesendet von: rtai-admin at rtai.org
05.10.2004 22:04
 
        An:     deepa.vijayaraghavan at mbtech-group.com
        Kopie:  rtai at rtai.org
        Thema:  Re: help reqd rgd example preempt pls(with denx core)


On 10/01/2004 09:39 AM deepa.vijayaraghavan at mbtech-group.com wrote:
> 
> hi all,
> there were a few mistakes, as the earlier mail was typed in a hurry..
> sorry abt that.
> I am referring to the example preempt, that demonstrates how a higher
> priority task and a lower priority task work together. My application is
> also sort of similar, hence clarity on this example will help me a great
> deal.
> I am using IBM ppc 440 based ebony board.
> In the functions rt_task_make_periodic(), if the second parameter is
> left as it is(now + tick_period), I get no output. Infact when I check
> if the task gets scheduled at all, by using rt_printk statements, I get
> no output.
> But if I set the delay to 0(or some small number), I get output so long
> as the init_module() runs. I get output based on the number of times the
> tasks get scheduled before the init_module() function is completed. I
> use 'insmod' for the loading the module.
> When I do rmmod, the tasks are terminated without errors.
> The same is the case with the 'Frank' example too.
> I use the 'One shot' timer. With 'periodic' timer, i see no output
> whatsoever.
> 
> Any help is highly appreciated.

Can you please provide more information on the problems and errors. What
version of RTAI are you using? Can we have a look to a test module
demostrating the problem?

Wolfgang.

_______________________________________________
RTAI mailing list
RTAI at rtai.org
https://mail.rtai.org/cgi-bin/mailman/listinfo/rtai

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mail.rtai.org/pipermail/rtai/attachments/20041006/921dc151/attachment.htm 


More information about the Rtai mailing list