comedi and rtai 3.1

Roberto Bucher roberto.bucher at supsi.ch
Wed Oct 6 20:58:09 CEST 2004


Since version RTAI-3.1 the different rtai_xxxxx modules are no more installed 
under /lib/<kernel>/... 

The "depmod" command can't solve all the dependencies of the comedi.o (or 
comedi.ko) module. You have to install 

rtai_hal
rtai_lxrt 

from the /usr/realtime/modules directory before any comedi driver.

In your case:

insmod /usr/realtime/modules/rtai_hal.ko
insmod /usr/realtime/modules/rtai_lxrt.ko

modprobe ni_atmio

I hope this will works

Roberto





On Wednesday 06 October 2004 17:29, you wrote:
>  I tried installing RTAI + comedi several times so far, but always ended up
> having troubles with unresolved symbols. I'm new to both RTAI and comedi
> and somewhat relieved that I'm not the only one experiencing problems. I'm
> using a vanilla 2.6.7 kernel and tried installing rtai 3.1 / cvs comedi on
> a PIII machine (using gcc 3.3.4). Although I got to run the rtai testsuite
> without problems, comedi won't recognize the driver module. (Whenever I
> installed comedi without rtai, it seemed to work).
>  I had basically given up on this, but thought that I could contribute the
> list of unresolved symbols to the current discussion (see the output
> below). Best regards,
> -Ingmar-
>
> # modprobe ni_atmio
> WARNING: Error inserting comedi
> (/lib/modules/2.6.7-adeos/comedi/comedi.ko): Unknown symbol in module, or
> unknown parameter (see dmesg)
> WARNING: Error inserting 8255 (/lib/modules/2.6.7-adeos/comedi/8255.ko):
> Unknown symbol in module, or unknown parameter (see dmesg)
> WARNING: Error inserting comedi_fc
> (/lib/modules/2.6.7-adeos/comedi/comedi_fc.ko): Unknown symbol in module,
> or unknown parameter (see dmesg)
> FATAL: Error inserting ni_atmio
> (/lib/modules/2.6.7-adeos/comedi/ni_atmio.ko): Unknown symbol in module, or
> unknown parameter (see dmesg)
>
> # dmesg
> ...
> comedi: Unknown symbol rt_request_srq
> comedi: Unknown symbol rtai_domain
> comedi: Unknown symbol rt_shutdown_irq
> comedi: Unknown symbol rt_enable_irq
> comedi: Unknown symbol rt_pend_linux_srq
> comedi: Unknown symbol rt_umount
> comedi: Unknown symbol rt_startup_irq
> comedi: Unknown symbol rt_free_srq
> comedi: Unknown symbol rt_mount
> comedi: Unknown symbol rt_request_irq
> comedi: Unknown symbol rt_release_irq
> 8255: Unknown symbol comedi_buf_put
> 8255: Unknown symbol comedi_event
> 8255: Unknown symbol range_unipolar5
> 8255: Unknown symbol comedi_driver_unregister
> 8255: Unknown symbol comedi_driver_register
> comedi_fc: Unknown symbol comedi_buf_read_free
> comedi_fc: Unknown symbol comedi_buf_write_alloc
> comedi_fc: Unknown symbol comedi_event
> comedi_fc: Unknown symbol comedi_buf_write_free
> comedi_fc: Unknown symbol comedi_buf_read_n_available
> comedi_fc: Unknown symbol comedi_buf_memcpy_to
> comedi_fc: Unknown symbol comedi_buf_memcpy_from
> ni_atmio: Unknown symbol cfc_write_array_to_buffer
> ni_atmio: Unknown symbol comedi_error
> ni_atmio: Unknown symbol rtai_domain
> ni_atmio: Unknown symbol subdev_8255_init
> ni_atmio: Unknown symbol rt_busy_sleep
> ni_atmio: Unknown symbol comedi_request_irq
> ni_atmio: Unknown symbol range_unknown
> ni_atmio: Unknown symbol subdev_8255_cleanup
> ni_atmio: Unknown symbol comedi_event
> ni_atmio: Unknown symbol range_unipolar5
> ni_atmio: Unknown symbol comedi_driver_unregister
> ni_atmio: Unknown symbol comedi_buf_get
> ni_atmio: Unknown symbol comedi_buf_read_n_available
> ni_atmio: Unknown symbol range_bipolar10
> ni_atmio: Unknown symbol comedi_driver_register
> ni_atmio: Unknown symbol comedi_free_irq
>
>
> _______________________________________________
> RTAI mailing list
> RTAI at rtai.org
> https://mail.rtai.org/cgi-bin/mailman/listinfo/rtai

-- 
University of Applied Sciences
of Southern Switzerland
Dept CS & EE
http://www.dti.supsi.ch/~bucher





More information about the Rtai mailing list