RTAI

Arne Linder alinder at uni-wuppertal.de
Fri Oct 8 14:02:18 CEST 2004


Hello,

Philippe Gerum schrieb:

> On Wed, 2004-10-06 at 17:22, Arne Linder wrote:
> 
>>Thanks for the quick response.
>>
>>Paolo Mantegazza schrieb:
>>
>>>[...] 
>>>- UP CELERON 1.8 Gz, 2.4/2.6, Suse 9.1, gcc-3.3.3
>>>
>>>and the compiler is the one that comes with the distribution.
>>
>>Hmmm, that is exactly the same we use. So the error must be somewhere 
>>else; perhaps it is in the kernel configuration. Could you provide us 
>>with a config file for the 2.6.x kernel? So we could recompile the whole 
>>stuff and see if the error persists.
>>
> 
> 
> Assuming that your glibc features the NPTL, is there any change with
> LD_ASSUME_KERNEL="2.4.18" set in your environment before running the
> testsuite ?
> 

Since we are using glibc 2.3.3 it should support NPTL, but the error 
message is the same. Both with LD_ASSUME_KERNEL="2.4.18" and 
LD_ASSUME_KERNEL="2.6.8.1", which we used for our last tests. It is the 
same than without setting LD_ASSUME_KERNEL.

Best regards

Arne Linder



-- 
Dipl.-Ing. Arne Linder
Electrical Machines and Drives
Faculty of Electrical, Information and Media Engineering
Wuppertal University
D-42097 Wuppertal
e-mail: alinder at uni-wuppertal.de





More information about the Rtai mailing list