RTAI

Arne Linder alinder at uni-wuppertal.de
Fri Oct 8 15:45:34 CEST 2004


Hoooray!

We got it running! Using a 2.6.7-kernel and the hal6-patch of RTAI-3.1 
it works. Both user-latency and user-preempt-examples run. Starting 
xtrailab gives no kernel oops.

Now we can proceed in our work.

Many thanks to all, who helped us in solving the problem.

Greetings from Wuppertal and have a nice weekend

Arne Linder

Arne Linder schrieb:

> Hello,
> 
> AlbertoSechi at libero.it schrieb:
> 
>> Hi,
>> I use the script "copy_comedi2kernel" that can be downloaded at
>> http://www.linux-usb-daq.co.uk/ . This script allows you to configure 
>> comedi
>> using the kernel configuration menu. In this site there is a comedi 
>> tarball with
>> the script inside. 
> 
> 
> We tried it this way, but got 2 disappointing results:
> 
> 1.) On the website given above, only downloads suitable for 
> 2.6.8.1-kernel were available, so we downloaded a prepatched kernel 
> 2.6.8.1 (with comedi), patched it with adeos patch (hal7) and compiled. 
> We used the .config provided from linux-usb-daq.co.uk and modified it, 
> e.g. activating adeos etc. The compilation worked, but the malfunctions 
> remained the same than before (user-latency: strange results; 
> user-preempt: kernel divide error; xrtailab: kernel oops).
> 
> 2.) Since using the software from linux-usb-daq.co.uk did not work, we 
> tried it again in the "old" way. We used the vanilla 2.6.7-kernel, 
> patched it with adeos (hal7-patch), removed the "COMEDI"-lines from the 
> configuration you gave us, but now the kernel compilation stops with:
>  > [...]
> 
>>   CC      arch/i386/kernel/asm-offsets.s
>> In file included from include/linux/sched.h:8,
>>                  from arch/i386/kernel/asm-offsets.c:7:
>> include/linux/adeos.h:310: error: conflicting types for 
>> `adeos_test_pipeline_from'
>> include/linux/adeos.h:276: error: previous declaration of 
>> `adeos_test_pipeline_from'
>> include/linux/adeos.h:317: error: conflicting types for 
>> `adeos_test_and_stall_pipeline_from'
>> include/linux/adeos.h:289: error: previous declaration of 
>> `adeos_test_and_stall_pipeline_from'
>> make[1]: *** [arch/i386/kernel/asm-offsets.s] Fehler 1
>> make: *** [arch/i386/kernel/asm-offsets.s] Fehler 2
> 
> 
> What is wrong now? Do you have another idea?
> 
> 
> Best regards
> 
> Arne Linder
> 


-- 
Dipl.-Ing. Arne Linder
Electrical Machines and Drives
Faculty of Electrical, Information and Media Engineering
Wuppertal University
D-42097 Wuppertal
e-mail: alinder at uni-wuppertal.de





More information about the Rtai mailing list