Calibration tool error

Umar Qureshey uq at ecs.fullerton.edu
Sun Oct 31 23:34:11 CET 2004


Hi,

On Sun, 31 Oct 2004, Gilles Chanteperdrix wrote:

> Umar Qureshey wrote:
>  > Hi,
>  >
>  > Ok, did a search on the archives and saw someone else with the same
>  > problem (~March 2004).  Borrowing a hint, I ran the calibration test with
>  > rtai-load --verbose.  Here's the contents of /var/log/kern.log:
>
> You are likely facing two problems. On the first run, the module
> 'rtai_malloc' loads successfully, but you have a problem when the
> program tries to open /dev/rtf/0. I can read on your first mail :
> RTAI[malloc]: loaded (global heap size=131072 bytes).
> (...)
> Error opening /dev/rtf/0

I think you are correct about these being two separate issues.  I have not
encountered the insmod page allocation failure subsequently, even with the
default 128K heap size.

>
> Some time ago, I asked you some questions about this problem, which you
> did not answer :

I apologize for the tardy response.  Somehow, I missed your
previous questions.

> - is the module rtai_fifos loaded by the 'run' script when launching the
>   application you are trying ?

Yes.  So far I have only run programs that came with the package i.e.
testsuite and calibration.  I run them using the run script or, for
debugging aid, using 'rtai-load --verbose'.

> - if yes, is it loaded successfully ?

The FIFO module loads successfully, as far as I can tell.  Insmod doesn't
complain and kernel logs are fine.  However, using the script, the modules
load, the program runs and fails, and the modules get unloaded very
quickly so I don't have a chance to run lsmod.  Loading rtai_fifos
manually using insmod always succeeds.

> - if it loads successfully, when it is loaded, do you see a /dev/rtf
>   directory with files inside ?

Manually loading rtai_fifo reveals nothing inside /dev/rtf.  Could it be
that devfs is mounted incorrectly?

To cancel devfs from the equation, I removed devfs support from the
kernel and recompiled the kernel and rtai.  Got the idea from this thread:

https://mail.rtai.org/pipermail/rtai/2004-March/006685.html

Now I am facing a totally new problem: running any RTAI programs
(i.e. calibration, testsuite, etc.) reboots the system immediately!
To find the offending module, I tried to load them manually.  Turns out
that `insmod rtai_hal.ko` reboots the system so no other module even gets
a chance.

I do have the pertinent device files in /dev:

/#ls /dev/rt* -l
crw-rw-rw-  1 root root  10, 254 Oct 30 09:41 /dev/rtai_shm
crw-rw----  1 root root  10, 135 Mar 14  2002 /dev/rtc
crw-r--r--  1 root root 150,   0 Oct 30 10:48 /dev/rtf0
crw-r--r--  1 root root 150,   1 Oct 30 10:48 /dev/rtf1
crw-r--r--  1 root root 150,   2 Oct 30 10:48 /dev/rtf2
crw-r--r--  1 root root 150,   3 Oct 30 10:48 /dev/rtf3
crw-r--r--  1 root root 150,   4 Oct 30 10:48 /dev/rtf4
crw-r--r--  1 root root 150,   5 Oct 30 10:48 /dev/rtf5
crw-r--r--  1 root root 150,   6 Oct 30 10:48 /dev/rtf6
crw-r--r--  1 root root 150,   7 Oct 30 10:48 /dev/rtf7

Any help appreciated.

Regards,

Umar







More information about the Rtai mailing list