RTAI on Cris

Simon Posnjak simon.posnjak at siol.net
Fri Sep 17 20:41:49 CEST 2004


V pet, 17.09.2004 ob 16:44 je Martin Andersson napisal(a):
> What is your problem? What does not work, what have you installed and 
> what error messeges do you get?
First I tried to compile 24.1.9. I applied the patch for the 2.4.20 kernel and then
followed the steps described in the README.CRIS. The kernel failed to
link because of some missing symbols (RTHAL_DO_TIMER_IRQ,
RTHAL_UNMASK_IF_NOT_RTAI, RTHAL_EI_IF_RTAI). Using the patch from
3.1-test5 (which is 95% the same as in 24.1.9) I got some weird problem
with prefix and not prefixed symbols. When I tried to compile 3.1-test5
i did not get the rtai.o module, so I just gave up...

> I have compiled the 3.1-test3 so I know that it can be done.
> 
> There are some patch files in the cris directories of recent rtai 
> releases which I would advice you to avoid as I have been unable to 
> compile the kernel with them. Look at 
> http://control.lth.se/~mandersson/rtai for a description of how it can 
> be done.
Hmmm, this looks better. I only found:
http://www.efd.lth.se/~d98mad/rtai.html
I will try again... Thank you for your help and links...

		Regards Simon






More information about the Rtai mailing list