pb with RTAI & EVB5272C3

Stephane MALLEM stephane.mallem at crde.fr
Tue Feb 8 12:37:51 CET 2005


Stephane MALLEM wrote:
 > Hi all
 >  
 > I try to install RTAI on a EVB5272C3 board.
 >  
 > I do this with version rtai-24.1.8, patch tarifa/20020227 and  >
uClinux-dist-20020220.  >  
 > All things are OK when I boot from dBUG.
 >  
 > The problem happen when I boot from u-boot-1.1.1 with uClinux only  >
patched with RTHAL.  >  
 > Nothing appear on the screen (only" ## starting application at  >
0x00020000")
 
 
 
Gilles Chanteperdrix answer :
 
Did you and compile u-boot with the CONFIG_SHOW_BOOT_PROGRESS option ?
 
 
Stephane Mallem :
 
Ok I use CONFIG_SHOW_BOOT_PROGRESS. U-boot is all right when I use bootm
0xfff00000 command.
 
But  uClinux doesn't start.
 
U-Boot 1.1.1- fff (Feb  4 2005 - 17:31:42)
 
CPU:   MOTOROLA MCF5272 (Mask:1)
Board: MOTOROLA MCF5272C3 EVB
DRAM:  16 MB
FLASH:  2 MB
In:    serial
Out:   serial
Err:   serial
--> bootm 0xfff00000
## Booting image at fff00000 ...
   Image Name:
   Image Type:   M68K Linux Kernel Image (gzip compressed)
   Data Size:    719611 Bytes = 702.7 kB
   Load Address: 00020000
   Entry Point:  00020000
   Verifying Checksum ... OK
   Uncompressing Kernel Image ... OK
 
Starting kernel ...
 
I wait for ever something else appear on the screen.
 
So I look Uclinux code and use a scope in combination with port A to see
activity.
 
My conclusion is : printk() execute 3 time, but nothing appear on TXD.
 
Uclinux crashes somewhere in free_area_init_node() in pagint_init() in
setup_arch() in init_start_kernel()
 
I have no idea what's happened !
 
 
 
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mail.rtai.org/pipermail/rtai/attachments/20050208/023b6ecc/attachment.htm 


More information about the Rtai mailing list